Login Hasło

#1 2009.08.27 13:35:03

slack
Użytkownik
Zarejestrowany: 2009.06.06
Posty: 45
System: Arch/Debian
Fluxbox: 1.1.1

Problem z uruchomieniem lxterminal

Witam, mam mały problem bo zainstalowałem "LXTerminal" i dopisałem go do menu fluxboksa , pojawił się w menu fluxbox , lecz gdy chcę uruchomić to nie działa  .Działa tylko jak wpiszę z konsoli roota .Tak to wygląda w pliku "menu":

Kod:

begin] (Fluxbox-1.1.1)
[encoding] {UTF-8}
      [exec] (xterm) {xterm}
      [exec] (firefox) {firefox}
      [exec] (lxterminal) {lxterminal}

A gdy wpiszę z konsoli usera to pisze:

Kod:

$ lxterminal
Naruszenie ochrony pamięci

Z góry dzięki za odpowiedz.Pozdrawiam.

Offline

 

#2 2009.08.27 14:48:24

Minio
Electric Castle resident
Skąd: Brno, Česko
Zarejestrowany: 2006.11.22
Posty: 546
System: Debian Testing
Fluxbox: Plasma 5.10.5 ;) (Fb 1.3.5)
WWW

Re: Problem z uruchomieniem lxterminal

Na moje oko paczka w dystrybucji jest spieprzona. Spróbuj zainstalować inną wersją (nowszą/starszą) i zgłoś błąd opiekunowi pakietu.

Jest też możliwe że problemem jest Twój hardware. Jeżeli masz możliwość, sprawdź pamięć i pojedynczo zamieniaj kolejne komponenty komputera.

Offline

 

#3 2009.08.27 16:55:04

slack
Użytkownik
Zarejestrowany: 2009.06.06
Posty: 45
System: Arch/Debian
Fluxbox: 1.1.1

Re: Problem z uruchomieniem lxterminal

Minio a może wiesz jak ustawic w fluxbox rozdzielczość na stałe bo gdy tylko uruchomie system zmienia mi się na 1280x1024, a ja chcę mieć 1024x768. gdzie trzeba dopisać

Kod:

xrandr -s 1024x768

Bym był wdzięczny za odpowiedz.Pozdrawiam!

Ostatnio edytowany przez slack (2009.08.27 16:55:23)

Offline

 

#4 2009.08.27 18:17:50

svL
Użytkownik
Zarejestrowany: 2009.08.23
Posty: 69
System: PLD Th
Fluxbox: 1.1.1

Re: Problem z uruchomieniem lxterminal

slack napisał(-a):

jak ustawic w fluxbox rozdzielczość na stałe

Edytuj /etc/X11/xorg.conf, w sekcji Screen wpis Modes "1024x768"


"God, root, what is difference?"

Offline

 

#5 2009.08.27 19:04:02

slack
Użytkownik
Zarejestrowany: 2009.06.06
Posty: 45
System: Arch/Debian
Fluxbox: 1.1.1

Re: Problem z uruchomieniem lxterminal

svL napisał(-a):

slack napisał(-a):

jak ustawic w fluxbox rozdzielczość na stałe

Edytuj /etc/X11/xorg.conf, w sekcji Screen wpis Modes "1024x768"

svL u mnie to jakos nie dziala , dopisalem do /etc/X11/xorg.conf

Kod:

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        SubSection "Display"
        Modes      "1024x768"
                Viewport   0 0
                Depth     1
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     4
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     8
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     15
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     16
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection

jak widac i nadal to samo sad

Offline

 

#6 2009.08.28 10:32:31

jerryS
Użytkownik
Zarejestrowany: 2007.11.26
Posty: 28
System: Arch
Fluxbox: 1.3.2

Re: Problem z uruchomieniem lxterminal

Minio napisał(-a):

Na moje oko paczka w dystrybucji jest spieprzona. Spróbuj zainstalować inną wersją (nowszą/starszą) i zgłoś błąd opiekunowi pakietu.

Jest też możliwe że problemem jest Twój hardware. Jeżeli masz możliwość, sprawdź pamięć i pojedynczo zamieniaj kolejne komponenty komputera.

Paczka (Arch) jest dobra, bo u mnie działa.

Zainstaluj roxterm.

Offline

 

#7 2009.08.28 17:56:52

svL
Użytkownik
Zarejestrowany: 2009.08.23
Posty: 69
System: PLD Th
Fluxbox: 1.1.1

Re: Problem z uruchomieniem lxterminal

slack a całą resztę xorg.conf masz w porządku


"God, root, what is difference?"

Offline

 

#8 2009.08.28 18:37:35

yoyoo2
Użytkownik
Zarejestrowany: 2009.01.17
Posty: 70

Re: Problem z uruchomieniem lxterminal

Dopisz modes 1024x768 dla kazdej sekcji, nie tylko dla tej z depth 1

Offline

 

#9 2009.08.28 21:49:07

Minio
Electric Castle resident
Skąd: Brno, Česko
Zarejestrowany: 2006.11.22
Posty: 546
System: Debian Testing
Fluxbox: Plasma 5.10.5 ;) (Fb 1.3.5)
WWW

Re: Problem z uruchomieniem lxterminal

Generalnie powinno tylko dla tej z Depth 24, bo niższej głębi kolorów używano w czasach kiedy ja jeszcze srałem w pieluchy. Dzisiaj nie ma żadnego powodu aby się ograniczać.

Chyba że ktoś chce się poczuć oldshoolowo wink .

Offline

 

#10 2009.08.29 07:32:44

slack
Użytkownik
Zarejestrowany: 2009.06.06
Posty: 45
System: Arch/Debian
Fluxbox: 1.1.1

Re: Problem z uruchomieniem lxterminal

Z rozdzielczoscią już sobie poradziłem zmieniłem w nvidia-settings dzięki jerrySsmile

Jeszcze takie pytanie mam, jak dopisać do menu fluxbox terminal roota aby sie uruchamiał , bo obecnie mam zwykły usera ,ewentualnie bym wpisał tylko hasło roota ? Z góry dzięki za odpowiedz.

Pozdrawiam:)

Ostatnio edytowany przez slack (2009.08.30 10:34:49)

Offline

 

#11 2009.08.31 20:22:46

azhag
Dozorca
Skąd: Warszawa
Zarejestrowany: 2006.11.21
Posty: 819
System: Debian Testing
Fluxbox: 1.3.5
WWW

Re: Problem z uruchomieniem lxterminal

slack napisał(-a):

Z rozdzielczoscią już sobie poradziłem zmieniłem w nvidia-settings dzięki jerrySsmile

Jeszcze takie pytanie mam, jak dopisać do menu fluxbox terminal roota aby sie uruchamiał , bo obecnie mam zwykły usera ,ewentualnie bym wpisał tylko hasło roota ? Z góry dzięki za odpowiedz.

Pozdrawiam:)

najlepiej skorzystaj z graficznego odpowiednika su:
- ktsuss
- gksu (zależny od GNOME)
- kdesu (zależny od KDE)

np.

Kod:

[exec] (Terminal @ root) {ktuss terminal}

w okienku wpisujesz hasło i masz terminal na roocie


Dr Chandra, will I dream?
pogoda w conky :: wybierz jabbera :: polski portal debiana :: registered linux user #403712

Offline

 

#12 2009.08.31 20:31:27

yoyoo2
Użytkownik
Zarejestrowany: 2009.01.17
Posty: 70

Re: Problem z uruchomieniem lxterminal

[exec] (Terminal roota) {terminal -e su} i nie musisz nic wiecej instalowac

Offline

 

#13 2009.09.01 06:55:51

slack
Użytkownik
Zarejestrowany: 2009.06.06
Posty: 45
System: Arch/Debian
Fluxbox: 1.1.1

Re: Problem z uruchomieniem lxterminal

Dzięki za odpowiedzi to działa. Mam tylko problemik z zapamiętanymi ustawieniami w roxterm i terminal, zainstalowałem też lxterminal ale w nim nie ma opcji wyłączenia paska menu. A z tymi dwoma to gdy ustawie przezroczystoś ,brak paska menu lub inny kolor tekstu i tła ,to gdy uruchomię ponownie są przywracane ustawienia standardowe. Ale gdy mam włączony jeden z tych terminali i z niego uruchomię drugi to wtedy są takie ustawienia jakie zmieniłem. Napisze jeszcze że zainstalowałem gnome-terminal i w nim wszystko działa i zapamiętuje ustawienia.Pozdro.

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson