Login Hasło

#1 2009.08.22 23:42:38

Biacho
Użytkownik
Skąd: Opole
Zarejestrowany: 2007.01.09
Posty: 49
System: Gentoo Linux.
Fluxbox: 1.1.1-r1

[SOLVED] Kolejny problem z przeźroczystością.

Witam. Ano i mam problem. Jak w temacie, przeźroczystość mi nie działa.
Postawiłem świerzy system i od samego początku nie działała, xorg.conf i pliki konfiguracyjne fluxboxa są przeniesione z poprzedniego systemu. Oczywiście wcześniej było wszystko w jak najlepszym porządku.

xorg.conf

Kod:

Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

    FontPath     "/usr/share/fonts/misc/"
    FontPath     "/usr/share/fonts/TTF/"
    FontPath     "/usr/share/fonts/OTF"
    FontPath     "/usr/share/fonts/Type1/"
    FontPath     "/usr/share/fonts/100dpi/"
    FontPath     "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
    Load  "glx"
    Load  "extmod"
    Load  "xtrap"
    Load  "record"
    Load  "GLcore"
    Load  "dbe"
#     Load  "dri"
#    Load  "freetype"
#    Load  "type1"
EndSection

Section "InputDevice"
    Identifier      "Keyboard0"
    Driver          "kbd"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "pl"
    Option        "XkbRules"    "xorg"
    
EndSection

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "ExplorerPS/2"
#    Option        "Protocol" "ExplorerPS/2"
    Option        "Protocol" "auto"
    Option        "Device" "/dev/input/mice"
    Option         "Buttons" "7"
    Option        "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
    Identifier   "Monitor0"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Device"
    Identifier  "Card0"
    Driver      "nvidia"
    VendorName  "nVidia Corporation"
    BoardName   "GeForce Go 7400"
    BusID       "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
        Modes     "1280x800"
    EndSubSection
EndSection
Section "Extensions"
#    Option  "Composite"  "Enable"
    Option  "NoLogo"      "true"     
EndSection

Ps. Fakt czy 'Option  "Composite"  "Enable"' jest zakomentowany czy odkomentowany nic nie zmienia.

.fluxbox/init :

Kod:

session.screen0.window.focus.alpha:    49
session.screen0.window.unfocus.alpha:    20
session.screen0.tabs.intitlebar:    true
session.screen0.tabs.usePixmap:    false
session.screen0.tabs.maxOver:    false
session.screen0.titlebar.left:    
session.screen0.titlebar.right:    Maximize Close 
session.screen0.tab.width:    64
session.screen0.tab.placement:    LeftTop
session.screen0.tab.rotatevertical:    True
session.screen0.tab.alignment:    Left
session.screen0.tab.height:    14
session.screen0.menu.alpha:    50
session.screen0.toolbar.layer:    Top
session.screen0.toolbar.tools:    iconbar, systemtray, clock
session.screen0.toolbar.visible:    true
session.screen0.toolbar.onhead:    0
session.screen0.toolbar.alpha:    80
session.screen0.toolbar.widthPercent:    100
session.screen0.toolbar.maxOver:    false
session.screen0.toolbar.autoHide:    false
session.screen0.toolbar.onTop:    False
session.screen0.toolbar.placement:    TopCenter
session.screen0.toolbar.height:    0
session.screen0.clientMenu.usePixmap:    true
session.screen0.iconbar.iconTextPadding:    10l
session.screen0.iconbar.deiconifyMode:    Follow
session.screen0.iconbar.usePixmap:    false
session.screen0.iconbar.iconWidth:    70
session.screen0.iconbar.wheelMode:    Screen
session.screen0.iconbar.mode:    {static groups} (workspace)
session.screen0.iconbar.alignment:    Relative
session.screen0.slit.layer:    Dock
session.screen0.slit.acceptKdeDockapps:    true
session.screen0.slit.alpha:    100
session.screen0.slit.onhead:    0
session.screen0.slit.direction:    Vertical
session.screen0.slit.onTop:    False
session.screen0.slit.autoHide:    false
session.screen0.slit.maxOver:    true
session.screen0.slit.placement:    RightCenter
session.screen0.overlay.lineWidth:    1
session.screen0.overlay.lineStyle:    LineSolid
session.screen0.overlay.joinStyle:    JoinMiter
session.screen0.overlay.capStyle:    CapNotLast
session.screen0.resizeMode:    Bottom
session.screen0.menuMode:    Delay
session.screen0.menuDelayClose:    0
session.screen0.autoRaise:    true
session.screen0.maxIgnoreIncrement:    true
session.screen0.maxDisableMove:    false
session.screen0.opaqueMove:    true
session.screen0.rootCommand:    ~/.fluxbox/autostart
session.screen0.colPlacementDirection:    TopToBottom
session.screen0.focusModel:    MouseFocus
session.screen0.decorateTransient:    false
session.screen0.demandsAttentionTimeout:    500
session.screen0.defaultDeco:    NORMAL
session.screen0.antialias:    true
session.screen0.workspaceNames:    1,2,3,4,5,6,7,Null,
session.screen0.menuDelay:    0
session.screen0.windowScrollReverse:    false
session.screen0.desktopwheeling:    true
session.screen0.strftimeFormat:    %T @ %A, %d %B
session.screen0.tooltipDelay:    500
session.screen0.windowScrollAction:    
session.screen0.allowRemoteActions:    false
session.screen0.userFollowModel:    SemiFollow
session.screen0.noFocusWhileTypingDelay:    0l
session.screen0.showwindowposition:    true
session.screen0.rowPlacementDirection:    LeftToRight
session.screen0.fullMaximization:    false
session.screen0.windowPlacement:    RowSmartPlacement
session.screen0.followModel:    Ignore
session.screen0.focusLastWindow:    true
session.screen0.sloppywindowgrouping:    true
session.screen0.edgeSnapThreshold:    0
session.screen0.workspacewarping:    true
session.screen0.focusNewWindows:    true
session.screen0.imageDither:    true
session.screen0.tabFocusModel:    SloppyTabFocus
session.screen0.workspaces:    8
session.screen0.windowMenu:    
session.screen0.clickRaises:    true
session.screen0.maxDisableResize:    false
session.screen0.reversewheeling:    false
session.titlebar.left:    
session.titlebar.right:    Maximize Close 
session.tabs:    true
session.slitlistFile:    ~/.fluxbox/slitlist
session.doubleClickInterval:    250
session.tabPadding:    0
session.appsFile:    ~/.fluxbox/apps
session.menuFile:    ~/.fluxbox/menu
session.opaqueMove:    False
session.groupFile:    ~/.fluxbox/groups
session.styleOverlay:    ~/.fluxbox/overlay
session.keyFile:    ~/.fluxbox/keys
session.colorsPerChannel:    4
session.cacheLife:    5l
session.focusTabMinWidth:    0
session.autoRaiseDelay:    250
session.cacheMax:    200l
session.ignoreBorder:    true
session.configVersion:    10
session.styleFile:    /home/biacho/.fluxbox/styles/biacho
session.imageDither:    true
session.tabsAttachArea:    Window
session.modKey:    Mod1
session.useMod1:    true
session.forcePseudoTransparency:    true
session.iconbar:    true
session.numLayers:    13

W czym może być problem ??

Fluxbox : 1.1.1-r1
Xorg : 7.4
Kernel :  2.6.30-gentoo-r4

Ostatnio edytowany przez Biacho (2009.08.23 18:28:21)


http://www.gentoo.org/images/gentoo-badge2.png

Offline

 

#2 2009.08.23 13:09:16

hiroshi07
Użytkownik
Zarejestrowany: 2009.07.12
Posty: 7

Re: [SOLVED] Kolejny problem z przeźroczystością.

Osobiście nie mam w Xorg.conf sekcji Extensions i przezroczystość mi działa. Czasem problemem jest włączona opcja Configuration-Przeźroczystość-Wymuś pseudo przeźroczystość. A tak nawiasem jak wygląda twoje ustawienie xcompmgr.

Offline

 

#3 2009.08.23 16:07:23

Biacho
Użytkownik
Skąd: Opole
Zarejestrowany: 2007.01.09
Posty: 49
System: Gentoo Linux.
Fluxbox: 1.1.1-r1

Re: [SOLVED] Kolejny problem z przeźroczystością.

hiroshi07 napisał(-a):

Osobiście nie mam w Xorg.conf sekcji Extensions i przezroczystość mi działa. Czasem problemem jest włączona opcja Configuration-Przeźroczystość-Wymuś pseudo przeźroczystość. A tak nawiasem jak wygląda twoje ustawienie xcompmgr.

Próbowałem z wyłączoną opcją wymuszania i jest to samo. Co do xcompmgr ... nie mam tej paczki w systemie.

Edit:
Dobra, paczke już mam, ale nie pojawił mi się żaden plik konfiguracyjny. Domyślam się, że musze go stworzyć. Pytanie gdzie i jaka ma wyglądać w środku ??

Ostatnio edytowany przez Biacho (2009.08.23 16:12:06)


http://www.gentoo.org/images/gentoo-badge2.png

Offline

 

#4 2009.08.23 17:00:43

hiroshi07
Użytkownik
Zarejestrowany: 2009.07.12
Posty: 7

Re: [SOLVED] Kolejny problem z przeźroczystością.

Jeszcze potrzebna paczka "transset". Xcompmgr możesz wypróbować w terminalu:

Kod:

xcompmgr -CfF -r7 -o.65 -l-10 -t-8 -D7

Opis opcji:

Kod:

man xcompmgr

niestety po angielsku. Gotowe ustawienie wpisz do pliku ~/.fluxbox/startup.
Poradniki:
http://wiki.archlinux.org/index.php/Xcompmgr
http://haxite.org/index.php3?site=artyk … amp;id=516 - to o ustawieniu Xorga

Ostatnio edytowany przez hiroshi07 (2009.08.23 17:02:11)

Offline

 

#5 2009.08.23 17:38:33

Biacho
Użytkownik
Skąd: Opole
Zarejestrowany: 2007.01.09
Posty: 49
System: Gentoo Linux.
Fluxbox: 1.1.1-r1

Re: [SOLVED] Kolejny problem z przeźroczystością.

Hmm... Dobra... to jest dziwne... po wrzuceniu w system dwój paczek i skorzystaniu z tutka a propo ustawień xorg'a poleconych przez hiroshi07, oraz kilku restartach Xów... zaczeło działać... smile No nic... dzięki za pomoc smile

Może komuś pomoże mój poprawiony Xorg:

Kod:

Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

    FontPath     "/usr/share/fonts/misc/"
    FontPath     "/usr/share/fonts/TTF/"
    FontPath     "/usr/share/fonts/OTF"
    FontPath     "/usr/share/fonts/Type1/"
    FontPath     "/usr/share/fonts/100dpi/"
    FontPath     "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
    Load  "glx"
    Load  "extmod"
    Load  "xtrap"
    Load  "record"
    Load  "GLcore"
    Load  "dbe"
#     Load  "dri"
#    Load  "freetype"
#    Load  "type1"
EndSection

Section "InputDevice"
    Identifier      "Keyboard0"
    Driver          "kbd"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "pl"
    Option        "XkbRules"    "xorg"
    
EndSection

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "ExplorerPS/2"
#    Option        "Protocol" "ExplorerPS/2"
    Option        "Protocol" "auto"
    Option        "Device" "/dev/input/mice"
    Option         "Buttons" "7"
    Option        "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
    Identifier   "Monitor0"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Device"
    Identifier  "Card0"
    Driver      "nvidia"
    VendorName  "nVidia Corporation"
    BoardName   "GeForce Go 7400"
    BusID       "PCI:1:0:0"
    Option      "RenderAccel" "on"
    Option      "AllowGLXWithComposite" "true"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
        Modes     "1280x800"
    EndSubSection
EndSection
Section "Extensions"
    Option  "Composite"  "Enable"
    Option  "NoLogo"      "true"     
EndSection

Ostatnio edytowany przez Biacho (2009.08.23 17:46:11)


http://www.gentoo.org/images/gentoo-badge2.png

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson