Login Hasło

  • Forum
  •  » Pozostałe
  •  » [+] Zmiana prompta nie działa w trybie tekstowym, w terminalach tak.

#1 2009.03.23 21:40:43

QzzY
Użytkownik
Zarejestrowany: 2009.01.24
Posty: 19

[+] Zmiana prompta nie działa w trybie tekstowym, w terminalach tak.

Mam następujący problem. Jestem użytkownikiem Debiana Squeeze. według poradnika znalezionego w dokumentacji gentoo zmieniłem sobie wyświetlanie prompta. Na koncie roota wszystko działa pięknie. na moim zmienia się tylko w terminalach spod Xów, w normalnych konsolach nie. Co ciekawe, po użyciu su wyświetla normalnie. Jakieś pomysły? zamiesczam mój plik .bashrc

Kod:

# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
[ -z "$PS1" ] && return

# don't put duplicate lines in the history. See bash(1) for more options
# don't overwrite GNU Midnight Commander's setting of `ignorespace'.
export HISTCONTROL=$HISTCONTROL${HISTCONTROL+,}ignoredups
# ... or force ignoredups and ignorespace
export HISTCONTROL=ignoreboth

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# make less more friendly for non-text input files, see lesspipe(1)
#[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "$debian_chroot" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
#case "$TERM" in
#    xterm-color) color_prompt=yes;;
#esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

#if [ -n "$force_color_prompt" ]; then
#    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
#    # We have color support; assume it's compliant with Ecma-48
#    # (ISO/IEC-6429). (Lack of such support is extremely rare, and such
#    # a case would tend to support setf rather than setaf.)
#    color_prompt=yes
#    else
#    color_prompt=
#    fi
#fi

#if [ "$color_prompt" = yes ]; then
#    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
#else
#    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
#fi
#unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
#case "$TERM" in
#xterm*|rxvt*)
#    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
#    ;;
#*)
#    ;;
#esac

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

#if [ -f ~/.bash_aliases ]; then
#    . ~/.bash_aliases
#fi

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
    eval "`dircolors -b`"
    alias ls='ls --color=auto'
    #alias dir='dir --color=auto'
    #alias vdir='vdir --color=auto'

    #alias grep='grep --color=auto'
    #alias fgrep='fgrep --color=auto'
    #alias egrep='egrep --color=auto'
fi

# some more ls aliases
#alias ll='ls -l'
#alias la='ls -A'
#alias l='ls -CF'

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if [ -f /etc/bash_completion ]; then
    . /etc/bash_completion
fi


if [ "$TERM" = "linux" ]
then
    # Pracujemy na konsoli systemowej lokalnie lub zdalnie
    export PS1="[\e[31;1m\] \u \w \[\e[0m\]] "
else
    # Nie używamy konsoli systemowej, przyjmujemy że jest to xterm
    export PS1="\[\e]2;\u@\H \w\a[\[\e[31;1m\] \u \[\e[0m\]] "
fi


######ALIASY
alias install='sudo aptitude install'

Ostatnio edytowany przez QzzY (2009.03.25 16:44:30)

Offline

 

#2 2009.03.24 00:24:07

Minio
Electric Castle resident
Skąd: Brno, Česko
Zarejestrowany: 2006.11.22
Posty: 546
System: Debian Testing
Fluxbox: Plasma 5.10.5 ;) (Fb 1.3.5)
WWW

Re: [+] Zmiana prompta nie działa w trybie tekstowym, w terminalach tak.

Nie znam się, ale pewnie chodzi o ten fragment:

QzzY napisał(-a):

Kod:

if [ "$TERM" = "linux" ]
then
    # Pracujemy na konsoli systemowej lokalnie lub zdalnie
    export PS1="[\e[31;1m\] \u \w \[\e[0m\]] "
else
    # Nie używamy konsoli systemowej, przyjmujemy że jest to xterm
    export PS1="\[\e]2;\u@\H \w\a[\[\e[31;1m\] \u \[\e[0m\]] "
fi

Może daj po prostu

Kod:

export PS1="\[\e]2;\u@\H \w\a[\[\e[31;1m\] \u \[\e[0m\]] "

bez żadnych ifów?

(PS. Dzięki za nakierowanie na zmienną HISTCONTROL, nie znałem jej wcześniej. A eliminuje jedno z najbardziej wkurzających zachowań bash-a.)

Offline

 

#3 2009.03.25 16:43:59

QzzY
Użytkownik
Zarejestrowany: 2009.01.24
Posty: 19

Re: [+] Zmiana prompta nie działa w trybie tekstowym, w terminalach tak.

problem leżał gdzie indziej. miałem utworzony pusty plik .bash_profile przez co plik .profile nie był wczytywany od razu a tam było zapisane ładowanie .bashrc. Przeniosłem jego zawartość do .bash_profile i pięknie działa. ten if jest potrzebny gdyż podczas pracy w konsoli potrzebuję mieć w znaku zachęty aktualny folder, a w terminalach X'owych ustawiłem tak aby przeniosło mi to do tytułu okna.

Offline

 

#4 2009.03.25 18:17:26

yoyoo2
Użytkownik
Zarejestrowany: 2009.01.17
Posty: 70

Re: [+] Zmiana prompta nie działa w trybie tekstowym, w terminalach tak.

zwyczajowo jest w bash_profile

Kod:

. $HOME/.bashrc

wpisane, ale nie wiem dlaczego, pewnie to jakies zachowanie zgodności z czymśtam - jak przenosłeś .bashrc do .bash_profile tomoze sie mieszac przy su albo przy połączeniu ssh

Offline

 

#5 2009.03.25 20:12:46

Minio
Electric Castle resident
Skąd: Brno, Česko
Zarejestrowany: 2006.11.22
Posty: 546
System: Debian Testing
Fluxbox: Plasma 5.10.5 ;) (Fb 1.3.5)
WWW

Re: [+] Zmiana prompta nie działa w trybie tekstowym, w terminalach tak.

.bash_profile jest czytany zaraz po zalogowaniu użytkownika.
.bashrc jest czytany przy każdym uruchomieniu powłoki bash.

Offline

 

#6 2009.03.25 21:37:18

QzzY
Użytkownik
Zarejestrowany: 2009.01.24
Posty: 19

Re: [+] Zmiana prompta nie działa w trybie tekstowym, w terminalach tak.

przeniosłem do .bash_profile zawartość .profile. ten drugi nie jest ładowany w przypadku obecności pierwszego i stąd kociokwik. pierwszy sam z siebie nie istniał, coś z jakiegoś howto robiłem i tam było coś z tym plikiem to go utworzyłem. nie dokończyłem chyba tego i dlatego został pusty. teraz jest już dobrze.

Offline

 
  • Forum
  •  » Pozostałe
  •  » [+] Zmiana prompta nie działa w trybie tekstowym, w terminalach tak.

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson