Login Hasło

#1 2009.03.15 20:11:22

RA
Użytkownik
Zarejestrowany: 2007.03.26
Posty: 6
System: Gentoo Linux
Fluxbox: 1.1.1

[Solved]Coś mi nie chce dodać do menu tapet, a kiedyś działało

Tu fragment mojej konfiguracji pliku menu

Kod:

[submenu] (Tapety)
      [wallpapers] (directory) {command}
      [wallpapers] (/RA/Tapety/RedWood.jpg) {feh –bg-scale}
      [wallpapers] (/RA/Tapety/ra.jpg) {feh –bg-scale}
      [wallpapers] (/RA/Tapety/Angelina.jpg) {feh –bg-scale}
      [wallpapers] (/RA/Tapety/36275miscladyofthelakexd5.jpg) {feh –bg-scale}
      [wallpapers] (/RA/Tapety/deathnote.jpg) {feh –bg-scale}
[end]

Najdziwniejsze, że vim mi nie zmienia koloru dla "[wallpapers]" tak jakby to nie było polecenie fluxboksa.

Ostatnio edytowany przez RA (2009.03.18 20:45:05)

Offline

 

#2 2009.03.15 20:33:11

endel
Moderator
Skąd: Krakow
Zarejestrowany: 2006.11.22
Posty: 247
System: Archlinux
Fluxbox:
WWW

Re: [Solved]Coś mi nie chce dodać do menu tapet, a kiedyś działało

nalezy podac sciezke do katalogu z tapetami:

Kod:

[submenu] (Tapety)
[wallpapers] (sciezka_do_katalogu_z_tapetami) {polecenie}
[end]

I need some sleep

Offline

 

#3 2009.03.16 20:24:00

RA
Użytkownik
Zarejestrowany: 2007.03.26
Posty: 6
System: Gentoo Linux
Fluxbox: 1.1.1

Re: [Solved]Coś mi nie chce dodać do menu tapet, a kiedyś działało

Pytanie dlaczego powyższe wpisy nie pojawiają się w menu?

Co jest źle w tym zapisie

Kod:

[wallpapers] (/RA/Tapety/RedWood.jpg) {feh –bg-scale}

Ścieżka, prawa dostępu są prawidłowe. Ja zgłupiałem, a to działało.

Fluxbox skompilowany z flagami: gnome imlib nls slit toolbar truetype vim-syntax xinerama

Offline

 

#4 2009.03.16 20:45:52

ilin
Palacz
Skąd: Siemianice
Zarejestrowany: 2008.01.02
Posty: 190
System: Debian Wheezy/Sid
Fluxbox: 1.3.5

Re: [Solved]Coś mi nie chce dodać do menu tapet, a kiedyś działało

Z tego co napisal endel to powinno to raczej wyglądać tak

Kod:

[wallpapers] (/home/RA/Tapety) {feh –bg-scale}

Offline

 

#5 2009.03.16 21:12:06

Minio
Electric Castle resident
Skąd: Brno, Česko
Zarejestrowany: 2006.11.22
Posty: 546
System: Debian Testing
Fluxbox: Plasma 5.10.5 ;) (Fb 1.3.5)
WWW

Re: [Solved]Coś mi nie chce dodać do menu tapet, a kiedyś działało

RA napisał(-a):

Co jest źle w tym zapisie

Kod:

[wallpapers] (/RA/Tapety/RedWood.jpg) {feh –bg-scale}

Ścieżka, prawa dostępu są prawidłowe. Ja zgłupiałem, a to działało.

A pokaż no wynik ls -lah /RA/Tapety/RedWood.jpg.

Offline

 

#6 2009.03.17 15:49:59

yoyoo2
Użytkownik
Zarejestrowany: 2009.01.17
Posty: 70

Re: [Solved]Coś mi nie chce dodać do menu tapet, a kiedyś działało

mozesz po katalogu dac /
czyli nie /home tylko /home/

Offline

 

#7 2009.03.17 18:26:55

RA
Użytkownik
Zarejestrowany: 2007.03.26
Posty: 6
System: Gentoo Linux
Fluxbox: 1.1.1

Re: [Solved]Coś mi nie chce dodać do menu tapet, a kiedyś działało

ls -lah /RA/Tapety/RedWood.jpg

wynik:

Kod:

-rw-r--r-- 1 ral ral 108K 2008-05-10  /RA/Tapety/RedWood.jpg

Jak już mówiłem ten zapis działał poprawnie w poprzedniej wersji kompilacji fluxboksa. Myślałem, że ktoś spotkał się z takimi objawami.

Offline

 

#8 2009.03.17 20:51:11

thalcave
czarny mag
Skąd: gdynia
Zarejestrowany: 2008.03.13
Posty: 63
System: Gentoo
Fluxbox: 1.3.1

Re: [Solved]Coś mi nie chce dodać do menu tapet, a kiedyś działało

Zatem troszkę zmodyfikowane rozwiązanie ilina

Kod:

[wallpapers] (/RA/Tapety/) {feh –bg-scale}

powinno działać.

Ostatnio edytowany przez thalcave (2009.03.17 20:53:15)


linux register user: 484281
"It's great to be here. It's great to be anywhere"
Keith Richards

Offline

 

#9 2009.03.17 21:35:06

RA
Użytkownik
Zarejestrowany: 2007.03.26
Posty: 6
System: Gentoo Linux
Fluxbox: 1.1.1

Re: [Solved]Coś mi nie chce dodać do menu tapet, a kiedyś działało

thalcave dzięki działa. Chyba przestaję myśleć samodzielnie, bo wydaje mi się, że i tę kombinację testowałem.

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson