Login Hasło

#1 2008.08.26 09:34:59

majusio
Użytkownik
Zarejestrowany: 2008.08.26
Posty: 23
System: Ubuntu 9.04
Fluxbox: 1.0.0

[SOLVED] Dźwięk przy uruchamianiu fluxboxa

Chciałem mieć ustawiony dźwięk podczas logowania do fluxboxa. Skorzystałem z tego poradnika:

Kod:

 Ustawienie dźwięku podczas logowania

Wpisz w terminalu:

sudo apt-get install sox
gedit ~/.fluxbox/startup

    * Znajdź linię: 

exec /usr/local/bin/fluxbox

    * Wpisz tę linię: 

play /usr/share/sounds/login.wav > /dev/null 2>&1 &

niestety nie działa. Może ma ktoś jakiś pomysł?

Offline

 

#2 2008.08.26 10:56:06

Minio
Electric Castle resident
Skąd: Brno, Česko
Zarejestrowany: 2006.11.22
Posty: 546
System: Debian Testing
Fluxbox: Plasma 5.10.5 ;) (Fb 1.3.5)
WWW

Re: [SOLVED] Dźwięk przy uruchamianiu fluxboxa

1. Pokaż cały plik ~/.fluxbox/startup.
2. Plik /usr/share/sounds/login.wav istnieje?
3. W jaki sposób uruchamiasz Fluxboksa?

Offline

 

#3 2008.08.26 12:40:51

majusio
Użytkownik
Zarejestrowany: 2008.08.26
Posty: 23
System: Ubuntu 9.04
Fluxbox: 1.0.0

Re: [SOLVED] Dźwięk przy uruchamianiu fluxboxa

Plik startup

Kod:

# fluxbox startup-script:
#
# Lines starting with a '#' are ignored.

# You can set your favourite wallpaper here if you don't want
# to do it from your style.
#
# fbsetbg -f /home/majusio/pictures/wallpaper.png
#
# This sets a black background

/usr/bin/fbsetroot -solid black

# This shows the fluxbox-splash-screen
# fbsetbg -C /usr/share/fluxbox/splash.jpg

# Other examples. Check man xset for details.
#
# Turn off beeps:
# xset -b
#
# Increase the keyboard repeat-rate:
# xset r rate 195 35
#
# Your own fonts-dir:
# xset +fp "/home/majusio/.fonts"
#
# Your favourite mouse cursor:
# xsetroot -cursor_name right_ptr
#
# Change your keymap:
# xmodmap "/home/majusio/.Xmodmap"



# Applications you want to run with fluxbox.
# MAKE SURE THAT APPS THAT KEEP RUNNING HAVE AN ''&'' AT THE END.
#
# unclutter -idle 2 &
# wmnd &
# wmsmixer -w &
# idesk &
  conky
  export OOO_FORCE_DESKTOP=gnome
# And last but not least we start fluxbox.
# Because it is the last app you have to run it with ''exec'' before it.

exec /usr/bin/fluxbox
play /usr/share/sounds/login.wav > /dev/null 2>&1 &
# or if you want to keep a log:
# exec /usr/bin/fluxbox -log "/home/majusio/.fluxbox/log"

Plik dźwiękowy o który pytałeś jest w tym folderze

Oprócz fluxboxa mam gnome więc odpalam go przez GDM

Offline

 

#4 2008.08.26 13:02:35

Minio
Electric Castle resident
Skąd: Brno, Česko
Zarejestrowany: 2006.11.22
Posty: 546
System: Debian Testing
Fluxbox: Plasma 5.10.5 ;) (Fb 1.3.5)
WWW

Re: [SOLVED] Dźwięk przy uruchamianiu fluxboxa

Podczas uruchamiania nigdy nie dochodzi do linijki z play. Kolejność powinna być odwrotna:

Kod:

play /usr/share/sounds/login.wav > /dev/null 2>&1 &
exec /usr/bin/fluxbox

Offline

 

#5 2008.08.26 15:23:16

majusio
Użytkownik
Zarejestrowany: 2008.08.26
Posty: 23
System: Ubuntu 9.04
Fluxbox: 1.0.0

Re: [SOLVED] Dźwięk przy uruchamianiu fluxboxa

Faktycznie. Teraz działa tak jak powinno. Dzięki wielkie za pomoc

Offline

 

#6 2008.08.27 11:35:42

Minio
Electric Castle resident
Skąd: Brno, Česko
Zarejestrowany: 2006.11.22
Posty: 546
System: Debian Testing
Fluxbox: Plasma 5.10.5 ;) (Fb 1.3.5)
WWW

Re: [SOLVED] Dźwięk przy uruchamianiu fluxboxa

smile
Dodałem „[SOLVED]” do nazwy wątku.

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson