Login Hasło

#1 2008.11.12 11:27:59

Sylar
Użytkownik
Zarejestrowany: 2008.11.12
Posty: 5
System: Arch Linux
Fluxbox: 1.1.1-1

[SOLVED]Problemy z Openoffice

Na początek, ponieważ jestem tu nowy, witam wszystkich na forum. Teraz pytanie: Po zainstalowaniu Openoffice (distro arch), poszczególne elementy (writer, calc) uruchamiają się bardzo długo, koło 30 sekund. Po uruchomieniu program momentalnie się zawiesza, pomaga tylko zabicie procesu soffice.bin w konsoli. Konsola daje przy uruchomieniu:

Kod:

(process:5767): GLib-GObject-CRITICAL **: gtype.c:2458: initialization assertion failed, use IA__g_type_init() prior to this function

(process:5767): GLib-GObject-CRITICAL **: g_type_interface_add_prerequisite: assertion `G_TYPE_IS_INTERFACE (interface_type)' failed

(process:5767): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

Przed zawieszeniem uda czasem uruchomić mi się menu i widzę, że jest ono bez styli GTK
Dodam jeszcze, że wcześniej miałem gnome i tam ta wersja OOo działała bez problemu.
Pozdrawiam.

Ostatnio edytowany przez Sylar (2008.11.17 15:02:24)

Offline

 

#2 2008.11.12 18:08:04

Minio
Electric Castle resident
Skąd: Brno, Česko
Zarejestrowany: 2006.11.22
Posty: 546
System: Debian Testing
Fluxbox: Plasma 5.10.5 ;) (Fb 1.3.5)
WWW

Re: [SOLVED]Problemy z Openoffice

Obawiam się, że ten problem ma się nijak do Fluxboksa.

Jeżeli masz okazję, zainstaluj inny menedżer okien i sprawdź czy problem występuje.

Jeżeli tak, udaj się z tym na jakieś forum Archa, ponieważ problem definitywnie jest związany z tą dystrybucją i dostępną na nią paczkę.

Offline

 

#3 2008.11.12 20:48:28

Sylar
Użytkownik
Zarejestrowany: 2008.11.12
Posty: 5
System: Arch Linux
Fluxbox: 1.1.1-1

Re: [SOLVED]Problemy z Openoffice

Problem tkwił w tym, że nie miałem zainstalowanego całego gliba. Różne gnomowe programy wymagają tego do działania, więc dociągają to sobie w zależnościach. W każdym razie, już wszystko działa, dzięki smile

Offline

 

#4 2009.01.10 18:06:26

małpa
Użytkownik
Zarejestrowany: 2008.12.11
Posty: 19
System: Debian Sid
Fluxbox:

Re: [SOLVED]Problemy z Openoffice

Korzystam z tego How To: Interfejs GTK/QT w OpenOffice pod Fluxboksem, ale niestety nie działa. Mam ooo-gnome i gtk; wklepałem komendę do ~/.bash_profile i nic (to ma być "profile" czy może "nazwa użytkownika"?).

Offline

 

#5 2009.01.10 20:51:11

Minio
Electric Castle resident
Skąd: Brno, Česko
Zarejestrowany: 2006.11.22
Posty: 546
System: Debian Testing
Fluxbox: Plasma 5.10.5 ;) (Fb 1.3.5)
WWW

Re: [SOLVED]Problemy z Openoffice

Spróbuj uruchomić przez

Kod:

OOO_FORCE_DESKTOP=gnome oowriter

W Debianie potrzebne są pakiety openoffice.org-gnome i openoffice.org-kde, ale wpominasz że je masz.

Offline

 

#6 2009.01.10 20:54:20

małpa
Użytkownik
Zarejestrowany: 2008.12.11
Posty: 19
System: Debian Sid
Fluxbox:

Re: [SOLVED]Problemy z Openoffice

Dzięki. Działa. smile

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson