Login Hasło

#1 2008.06.17 14:06:06

mlo
Nowy użytkownik
Zarejestrowany: 2008.06.17
Posty: 3

brak reakcji na zawartosc apps

wsumie to dwa problemy:
1) w pliku apps mam:

Kod:

(..)
[app] (name=ipager) (class=IPager)
  [Sticky]      {yes}
  [Layer]       {2}
[end]
[startup]  {ipager}
(..)

jak dam startx to ipager nie zwraca uwagi na wplisy w apps i jest ustawiony "Na dno", probowalem zmienaic wartosc Layer lecz nic to nie dawalo..

2) w pliku apps mam:

Kod:

(..)
[app] (name=XMMS_Player) (class=xmms)
  [Workspace]   {3}
[end]
[app] (name=XMMS_Playlist) (class=xmms)
  [Workspace]   {3}
[end]
[startup]  {xmms -p}
(..)

jednak jedynie player otwiera sie na czwartym pulpicie a lista na pierwszym..

jeszcze podrodze mam

Kod:

[startup]  {pypanel}

ktory nie zawsze sie odpala

troche info:

Kod:

%uname -sr
FreeBSD 6.3-RELEASE
%fluxbox -v
FbTk::FbString: setup converts for local codeset = ISO8859-2
Fluxbox 1.0.0 : (c) 2001-2007 Fluxbox Team

szukalem troche na tym forum jednak rozwiazania moich problemow nei znalazlem, moze ktos sie spotkal z takimi problemami?

Offline

 

#2 2008.06.17 18:46:55

vermaden
Użytkownik
Skąd: pl_PL.lodz
Zarejestrowany: 2007.04.04
Posty: 252
System: FreeBSD UNIX 7.0
Fluxbox: SVN
WWW

Re: brak reakcji na zawartosc apps

Zeby [startup] dzialal, to trza odpalac fluxboxa przez startfluxbox chyba, nigdy tego nie uzywam i startuje wszystko przez ~/.xinitrc wiec z tym ci nie pomoge, co do drugiego, to nie pamietam zeby fluxbox przyjmowal i name i class naraz w ~/.fluxbox/apps ja zawsze mialem jedno ustawione tylko, albo name albo class, albo role czasami, do zbieranai informacji co mam tam wstawic uzywam swojego skryptu:

Kod:

#!/bin/sh

string=`xprop WM_CLASS WM_NAME WM_WINDOW_ROLE | grep -v 'not found'`

echo -n ${string} | grep -q WM_WINDOW_ROLE
if [ ${?} -eq 0 ]; then
     wm_role=`echo -n ${string} | cut -d '"' -f 2`
  wm_class_1=`echo -n ${string} | cut -d '"' -f 4`
  wm_class_2=`echo -n ${string} | cut -d '"' -f 6`
     wm_name=`echo -n ${string} | cut -d '"' -f 8`
else
  wm_class_1=`echo -n ${string} | cut -d '"' -f 2`
  wm_class_2=`echo -n ${string} | cut -d '"' -f 4`
     wm_name=`echo -n ${string} | cut -d '"' -f 6`
fi

(
  echo "available properties:"
  echo
  echo " xprop   fluxbox   value"
  echo " -----   -------   -----"
  echo " CLASS1   name     ${wm_class_1}"  # first field of WM_CLASS
  echo " CLASS2   class    ${wm_class_2}"  # second field of WM_CLASS
  echo "  NAME    title    ${wm_name}"     # WM_NAME property
  if [ ${wm_role} ]; then
    echo "  ROLE    role     ${wm_role}"   # WM_WINDOW_ROLE property
  fi
) | xmessage -title "available properties" -file - -center

zbierz jeszcze raz name, class albo role tym skryptem, ustaw tylko jedno i sprawdz.


"religions, worst damnation of mankind"
vermaden's: links resources deviantart

Offline

 

#3 2008.06.17 20:57:35

mlo
Nowy użytkownik
Zarejestrowany: 2008.06.17
Posty: 3

Re: brak reakcji na zawartosc apps

niestety nic..
co do pypanel to chodzi o to ze czasem startuje czasem nie i to mnie dziwi..
odnosnie ipager i xmms to nic nie dalo wstawiania name czy class pojedynczo czy razem.. nic.. propowalem przes [startup] i przex .xinitrc nic z Twojego posta nei podziałalo mimo to thx za checi wink

moze jakies inne sugestie?

Offline

 

#4 2008.06.17 21:22:39

vermaden
Użytkownik
Skąd: pl_PL.lodz
Zarejestrowany: 2007.04.04
Posty: 252
System: FreeBSD UNIX 7.0
Fluxbox: SVN
WWW

Re: brak reakcji na zawartosc apps

Kawalek mojego ~/.fluxbox/apps wyglada tak i wszystko z niego dziala:

Kod:

[app] (feh)
  [Position]    (LOWERRIGHT) {50 70}
[end]

[app] (role=gimp-toolbox)
  [Workspace]   {3}
  [Position]    (UPPERLEFT) {0 19}
  [Deco]        {BORDER}
[end]

[app] (role=gimp-dock)
  [Workspace]   {3}
  [Position]    (UPPERRIGHT) {0 0}
  [Deco]        {BORDER}
[end]

[app] (role=gimp-image-window)
  [Workspace]   {3}
  [Deco]        {NORMAL}
[end]

[app] (gimp.*)
  [Workspace]   {3}
  [Deco]        {BORDER}
[end]

Nie wiem w czym moze byc problem szczerze mowiac, mysle ze powinienes zaczac od poczatku, czyli dodac 1 poprawny wpis dla na przyklad xterm i Deco:

Kod:

[app] (xterm)
    [Deco]        {BORDER}
[end]

jezeli cos tak prostego nie zadziala to cos jest sporo nie teges.

sprobuj tez odpalic fluxbox tak z ~/.xinitrc:

Kod:

exec fluxbox -verbose -log ~/fluxbox.log

Jak tu nic nie znajdziesz, to moze skontaktuj sie z developerami flxuboxa?

szczegolnie polecam kanal IRC #fluxbox
http://fluxbox.org/help/


"religions, worst damnation of mankind"
vermaden's: links resources deviantart

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson