Login Hasło

#1 2008.03.07 20:09:04

jedrzej123456789
Nowy użytkownik
Zarejestrowany: 2008.03.07
Posty: 3

Brak reakcji fluxa na klawisze myszki (ogólnie nieużyteczność)

Mam Ubuntu 7.10 z GNOME. Wszystko działało w porządku. Ale postanowiłem zainstalować fluxboxa. Po wydaniu komendy

    sudo aptitude install fluxbox


nie wyświetlił się żaden błąd. Jednak po włączeniu Fluxa nie mogę nic zrobić ponieważ żadne menu nie chce się otworzyć. Po prostu nie reaguje na wciśnięcie żadnych klawiszy. kursor się porusza ale już prawy klawisz myszy nie działa. Próbowałem też zainstalować fluxbuntu ale system nie zaskakuje z CD chociaż jest odpowiednio ustawiony. Proszę o pomoc bądź z Fluxboxem (lepiej) albo z Fluxbuntu (które ściągałem z oficjlnej strony).

Offline

 

#2 2008.03.07 20:57:19

azhag
Dozorca
Skąd: Warszawa
Zarejestrowany: 2006.11.21
Posty: 819
System: Debian Testing
Fluxbox: 1.3.5
WWW

Re: Brak reakcji fluxa na klawisze myszki (ogólnie nieużyteczność)

Wpisz:

Kod:

OnDesktop Mouse1 :hideMenus
OnDesktop Mouse2 :workspaceMenu
OnDesktop Mouse3 :rootMenu
OnDesktop Mouse4 :nextWorkspace
OnDesktop Mouse5 :prevWorkspace

w pliku ~/.fluxbox/keys.


Dr Chandra, will I dream?
pogoda w conky :: wybierz jabbera :: polski portal debiana :: registered linux user #403712

Offline

 

#3 2008.03.08 10:36:31

jedrzej123456789
Nowy użytkownik
Zarejestrowany: 2008.03.07
Posty: 3

Re: Brak reakcji fluxa na klawisze myszki (ogólnie nieużyteczność)

miałem to wpisane.
Plik ~/.fluxbox/keys wygląda tak:

Kod:

OnDesktop Mouse1 :hideMenus
OnDesktop Mouse2 :workspaceMenu
OnDesktop Mouse3 :rootMenu
OnDesktop Mouse4 :nextWorkspace
OnDesktop Mouse5 :prevWorkspace

Mod1 Tab :NextWindow
Mod1 Shift Tab :PrevWindow
Mod1 F1 :Workspace 1
Mod1 F2 :Workspace 2
Mod1 F3 :Workspace 3
Mod1 F4 :Workspace 4
Mod1 F5 :Workspace 5
Mod1 F6 :Workspace 6
Mod1 F7 :Workspace 7
Mod1 F8 :Workspace 8
Mod1 F9 :Workspace 9
Mod1 F10 :Workspace 10
Mod1 F11 :Workspace 11
Mod1 F12 :Workspace 12

może brakuje czegos jeszcze.

Alb jakieś inne źródło skąd mogę pobrać działającego fluxboxa.

Co do Fluxbuntu to sumy sie zgadzają, na VirtualBoxie działa ale płyta się nie bootuje.

Offline

 

#4 2008.03.08 11:01:15

Minio
Electric Castle resident
Skąd: Brno, Česko
Zarejestrowany: 2006.11.22
Posty: 546
System: Debian Testing
Fluxbox: Plasma 5.10.5 ;) (Fb 1.3.5)
WWW

Re: Brak reakcji fluxa na klawisze myszki (ogólnie nieużyteczność)

Pomocny nie będę, ale:
Przed Państwem kolejny dowód świadczący o marnej jakości Łubudubuntu.

Offline

 

#5 2008.03.08 11:07:24

azhag
Dozorca
Skąd: Warszawa
Zarejestrowany: 2006.11.21
Posty: 819
System: Debian Testing
Fluxbox: 1.3.5
WWW

Re: Brak reakcji fluxa na klawisze myszki (ogólnie nieużyteczność)

Hm, czyli jakiś większy porblem.

Pokaż jeszcze ~/.fluxbox/init


Dr Chandra, will I dream?
pogoda w conky :: wybierz jabbera :: polski portal debiana :: registered linux user #403712

Offline

 

#6 2008.03.08 11:17:07

paatos
Użytkownik
Skąd: Gliwice
Zarejestrowany: 2006.12.03
Posty: 62
System: Debian Squeeze
Fluxbox: Gnome?

Re: Brak reakcji fluxa na klawisze myszki (ogólnie nieużyteczność)

Stawiam na źle skonfigurowany xorg.conf - pokaż go

Offline

 

#7 2008.03.08 11:22:48

jedrzej123456789
Nowy użytkownik
Zarejestrowany: 2008.03.07
Posty: 3

Re: Brak reakcji fluxa na klawisze myszki (ogólnie nieużyteczność)

~/.fluxbox/init

Kod:

session.screen0.overlay.lineWidth:      1
session.screen0.overlay.lineStyle:      LineSolid
session.screen0.overlay.joinStyle:      JoinMiter
session.screen0.overlay.capStyle:       CapNotLast
session.screen0.tabs.maxOver:   false
session.screen0.tabs.intitlebar:        true
session.screen0.iconbar.iconTextPadding:        10l
session.screen0.iconbar.alignment:      Relative
session.screen0.iconbar.mode:   Icons
session.screen0.iconbar.iconWidth:      70
session.screen0.iconbar.wheelMode:      Screen
session.screen0.iconbar.usePixmap:      true
session.screen0.window.focus.alpha:     255
session.screen0.window.unfocus.alpha:   255
session.screen0.menu.alpha:     255
session.screen0.tab.placement:  TopLeft
session.screen0.tab.width:      64
session.screen0.tab.height:     16
session.screen0.toolbar.layer:  Dock
session.screen0.toolbar.alpha:  255
session.screen0.toolbar.placement:      BottomCenter
session.screen0.toolbar.onhead: 0
session.screen0.toolbar.visible:        true
session.screen0.toolbar.maxOver:        false
session.screen0.toolbar.onTop:  False
session.screen0.toolbar.widthPercent:   66
session.screen0.toolbar.height: 0
session.screen0.toolbar.autoHide:       false
session.screen0.toolbar.tools:  workspacename, prevworkspace, nextworkspace, iconbar, systemtray, prevwindow, nextwindow, clock
session.screen0.slit.layer:     Dock
session.screen0.slit.alpha:     255
session.screen0.slit.placement: BottomRight
session.screen0.slit.onhead:    0
session.screen0.slit.autoHide:  false
session.screen0.slit.direction: Vertical
session.screen0.slit.maxOver:   false
session.screen0.slit.onTop:     False
session.screen0.clickRaises:    true
session.screen0.reversewheeling:        false
session.screen0.windowScrollReverse:    false
session.screen0.colPlacementDirection:  TopToBottom
session.screen0.focusModel:     ClickFocus
session.screen0.tabFocusModel:  ClickToTabFocus
session.screen0.allowRemoteActions:     false
session.screen0.fullMaximization:       false
session.screen0.menuMode:       Delay
session.screen0.windowMenu:
session.screen0.decorateTransient:      true
session.screen0.edgeSnapThreshold:      0
session.screen0.windowPlacement:        RowSmartPlacement
session.screen0.menuDelay:      0
session.screen0.defaultDeco:    NORMAL
session.screen0.rowPlacementDirection:  LeftToRight
session.screen0.showwindowposition:     true
session.screen0.followModel:    Ignore
session.screen0.rootCommand:
session.screen0.autoRaise:      true
session.screen0.opaqueMove:     false
session.screen0.windowScrollAction:
session.screen0.workspacewarping:       true
session.screen0.workspaces:     4
session.screen0.resizeMode:     Bottom
session.screen0.userFollowModel:        Follow
session.screen0.workspaceNames: one,two,three,four,
session.screen0.imageDither:    false
session.screen0.desktopwheeling:        true
session.screen0.menuDelayClose: 0
session.screen0.strftimeFormat: %k:%M
session.screen0.focusLastWindow:        True
session.screen0.focusNewWindows:        true
session.tabPadding:     0
session.keyFile:        ~/.fluxbox/keys
session.opaqueMove:     False
session.tabsAttachArea: Window
session.groupFile:      ~/.fluxbox/groups
session.cacheLife:      5l
session.colorsPerChannel:       4
session.configVersion:  1
session.forcePseudoTransparency:        false
session.modKey: Mod1
session.menuFile:       ~/.fluxbox/menu
session.doubleClickInterval:    250
session.ignoreBorder:   false
session.imageDither:    True
session.cacheMax:       200l
session.appsFile:       ~/.fluxbox/apps
session.slitlistFile:   ~/.fluxbox/slitlist
session.styleOverlay:   ~/.fluxbox/overlay
session.autoRaiseDelay: 250
session.styleFile:      /usr/share/fluxbox/styles/BlueNight

xorg.conf:

Kod:

# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "pl"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"        "/dev/input/mice"
        Option          "Protocol"      "ImPS/2"
        Option          "ZAxisMapping"  "4 5"
        Option          "Emulate3Buttons"       "true"
EndSection

Section "InputDevice"
        Driver          "wacom"
        Identifier      "stylus"
        Option          "Device"        "/dev/input/wacom"
        Option          "Type"  "stylus"
        Option          "ForceDevice"   "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
        Driver          "wacom"
        Identifier      "eraser"
        Option          "Device"        "/dev/input/wacom"
        Option          "Type"  "eraser" Option          "ForceDevice"   "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
        Driver          "wacom"
        Identifier      "cursor"
        Option          "Device"        "/dev/input/wacom"
        Option          "Type"  "cursor"
        Option          "ForceDevice"   "ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
        Identifier      "nVidia Corporation G80 [GeForce 8600 GT]"
        Driver          "nvidia"
        Busid           "PCI:1:0:0"
        Option          "AddARGBVisuals"        "True"
        Option          "AddARGBGLXVisuals"     "True"
        Option          "NoLogo"        "True"
        Option              "AddARGBGLXVisuals"     "true"
        Option              "AllowGLXWithComposite" "true"
        Option              "TripleBuffer"          "true
        #Option             "CursosShadow"          "true"
        Option              "UseEdidFreqs"          "true"
        Option              "RenderAccel"           "true"
        Option              "backingstore"          "true"
        EndSection

Section "Monitor"
        Identifier      "Generic Monitor"
        Option          "DPMS"
        Horizsync       30-70
        Vertrefresh     50-160
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "nVidia Corporation G80 [GeForce 8600 GT]"
        Monitor         "Generic Monitor"
        Defaultdepth    24
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
  screen "Default Screen"
        Inputdevice     "Generic Keyboard"
        Inputdevice     "Configured Mouse"

        # Uncomment if you have a wacom tablet
        #       InputDevice     "stylus"        "SendCoreEvents"
        #       InputDevice     "cursor"        "SendCoreEvents"
 #       InputDevice     "eraser"        "SendCoreEvents"
EndSection
Section "Module"
        Load            "glx"
        Load            "dbe"
EndSection

Section "Extensions"
        Option  "Composite"     "Enable"
EndSection

Ostatnio edytowany przez jedrzej123456789 (2008.03.08 11:27:42)

Offline

 

#8 2008.03.16 21:38:12

karolp1993
Użytkownik
Zarejestrowany: 2007.09.23
Posty: 12

Re: Brak reakcji fluxa na klawisze myszki (ogólnie nieużyteczność)

Mam to samo, prosimy o pomoc.

Offline

 

#9 2008.03.16 22:11:10

Moebius
o¤°`°¤o,¸¸¸,o¤°
Skąd: /dev/tty1
Zarejestrowany: 2007.02.26
Posty: 202
System: Gentoo
Fluxbox: ist Krieg!

Re: Brak reakcji fluxa na klawisze myszki (ogólnie nieużyteczność)

Problemy występują tylko z livecd ubuntu? Tylko z fluxbox'em? Na innym distro lub np. pod Gnome działa dobrze?

proponowałbym na początek może zakomentować

Kod:

 Option          "Emulate3Buttons"       "true"

nie pomoże, to może spróbuj zmienić

Kod:

 Option          "Protocol"      "ImPS/2"

na

Kod:

Option          "Protocol"      "auto"

Dodaj może do .fluxbox/menu jakiś skrót klawiszowy aktywujący menu, albo chociaż aktywujący xterm'a czy cokolwiek, zobacz czy na to reaguje.


Teraz, gdy już nauczyliśmy się latać w powietrzu jak ptaki, pływać pod wodą jak ryby, brakuje nam tylko jednego: nauczyć się żyć na ziemi jak ludzie.

Offline

 

#10 2008.03.17 14:56:40

karolp1993
Użytkownik
Zarejestrowany: 2007.09.23
Posty: 12

Re: Brak reakcji fluxa na klawisze myszki (ogólnie nieużyteczność)

No ja też miałem Emulate3Buttons, ale zahashowałem . KDE działa ok.
Zrobiłem tak że
Mod1 F1 :xterm
OnDesktop Mouse1 :xterm
i nie reaguje.

Ostatnio edytowany przez karolp1993 (2008.03.17 15:01:42)

Offline

 

#11 2008.03.17 17:16:37

Moebius
o¤°`°¤o,¸¸¸,o¤°
Skąd: /dev/tty1
Zarejestrowany: 2007.02.26
Posty: 202
System: Gentoo
Fluxbox: ist Krieg!

Re: Brak reakcji fluxa na klawisze myszki (ogólnie nieużyteczność)

reaguje chociaż na ctrl+alt+F2? albo ctrl+alt+bakspace?
ponawiam pytanie, próbowałeś na livecd innych distro opartych o fluxbox'a? dsl na przykład?


Teraz, gdy już nauczyliśmy się latać w powietrzu jak ptaki, pływać pod wodą jak ryby, brakuje nam tylko jednego: nauczyć się żyć na ziemi jak ludzie.

Offline

 

#12 2008.03.17 18:12:25

karolp1993
Użytkownik
Zarejestrowany: 2007.09.23
Posty: 12

Re: Brak reakcji fluxa na klawisze myszki (ogólnie nieużyteczność)

Nie, mam tylko kubuntu. Czy można zrobić tak żeby odpalić kubuntu i fluxboxa zainstalować?
ctrl+alt+backspace działa,

Offline

 

#13 2008.03.17 19:17:16

karolp1993
Użytkownik
Zarejestrowany: 2007.09.23
Posty: 12

Re: Brak reakcji fluxa na klawisze myszki (ogólnie nieużyteczność)

Mi się wydaje że przyciski myszki jakoś inaczej się nazywają, bo jak otworze menu workspace i chce kliknąć na four to nie klika hmm
Klawisze też nie chodzą.

Ostatnio edytowany przez karolp1993 (2008.03.17 19:21:17)

Offline

 

#14 2008.03.17 20:43:43

Minio
Electric Castle resident
Skąd: Brno, Česko
Zarejestrowany: 2006.11.22
Posty: 546
System: Debian Testing
Fluxbox: Plasma 5.10.5 ;) (Fb 1.3.5)
WWW

Re: Brak reakcji fluxa na klawisze myszki (ogólnie nieużyteczność)

karolp1993 napisał(-a):

Zrobiłem tak że
Mod1 F1 :xterm
OnDesktop Mouse1 :xterm
i nie reaguje.

Nie reaguje, bo programy mają w zwyczaju reagować tylko na to, na co reakcje im zaprogramowano. Powinno być:

Kod:

Mod1 F1 :ExecCommand xterm
OnDesktop Mouse1 :ExecCommand xterm

Odpowiając na Twoje dalsze pytanie: tak, możesz zainstalować (K)Ubuntu i później przy pomocy Synaptica/ apt-get/ aptitude Fluxboksa. Tylko nie gwarantuje to rozwiązania problemu.

Offline

 

#15 2008.03.17 22:01:42

karolp1993
Użytkownik
Zarejestrowany: 2007.09.23
Posty: 12

Re: Brak reakcji fluxa na klawisze myszki (ogólnie nieużyteczność)

O dziwo nie ma paczki fluxbox w kubuntu hmm

Offline

 

#16 2008.03.17 23:09:37

vermaden
Użytkownik
Skąd: pl_PL.lodz
Zarejestrowany: 2007.04.04
Posty: 252
System: FreeBSD UNIX 7.0
Fluxbox: SVN
WWW

Re: Brak reakcji fluxa na klawisze myszki (ogólnie nieużyteczność)

karolp1993 napisał(-a):

O dziwo nie ma paczki fluxbox w kubuntu hmm

to moze fluxbuntu? smile

http://fluxbuntu.org


"religions, worst damnation of mankind"
vermaden's: links resources deviantart

Offline

 

#17 2008.03.18 21:31:31

karolp1993
Użytkownik
Zarejestrowany: 2007.09.23
Posty: 12

Re: Brak reakcji fluxa na klawisze myszki (ogólnie nieużyteczność)

Już wszystko działa, zrobiłem update-menus.

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson