Login Hasło

#1 2007.09.30 23:18:24

big.l
Użytkownik
Zarejestrowany: 2007.09.30
Posty: 30

"apps file failure"

Witam

Debian Etch, fluxbox zainstalowany dopiero co przez apt-get (z repo)

uruchamiam go za pomocą "startx /usr/local/bin/fluxbox"

Po wyłączeniu widzę, że w trybie txt jest pełno linijek typu:

apps file failure
apps file failure
apps file failure
apps file failure
apps file failure
apps file failure
...
..
.

itd. Nie konfigurowałem żadnego apps. Jak to naprawić ?

Pozdrawiam

Offline

 

#2 2007.09.30 23:31:40

vermaden
Użytkownik
Skąd: pl_PL.lodz
Zarejestrowany: 2007.04.04
Posty: 252
System: FreeBSD UNIX 7.0
Fluxbox: SVN
WWW

Re: "apps file failure"

Kod:

$ :> ~/.fluxbox/apps

spawdz teraz czy sypie bledami dalej


"religions, worst damnation of mankind"
vermaden's: links resources deviantart

Offline

 

#3 2007.10.01 07:35:29

big.l
Użytkownik
Zarejestrowany: 2007.09.30
Posty: 30

Re: "apps file failure"

nie ma takiej komendy hmm

Offline

 

#4 2007.10.01 08:19:17

azhag
Dozorca
Skąd: Warszawa
Zarejestrowany: 2006.11.21
Posty: 819
System: Debian Testing
Fluxbox: 1.3.5
WWW

Re: "apps file failure"

pokaż wynik polecenia

Kod:

grep apps ~/.fluxbox/init

oraz zawartość ~/.fluxbox/apps


Dr Chandra, will I dream?
pogoda w conky :: wybierz jabbera :: polski portal debiana :: registered linux user #403712

Offline

 

#5 2007.10.01 09:25:30

vermaden
Użytkownik
Skąd: pl_PL.lodz
Zarejestrowany: 2007.04.04
Posty: 252
System: FreeBSD UNIX 7.0
Fluxbox: SVN
WWW

Re: "apps file failure"

big.l napisał(-a):

nie ma takiej komendy hmm

zaloze sie ze wkleiles to tak:
bash$ $ :> ~/.fluxbox/apps
bash: $: command not found

a powinienes wkleic to:

bash$ :> ~/.fluxbox/apps
bash$


"religions, worst damnation of mankind"
vermaden's: links resources deviantart

Offline

 

#6 2007.10.01 17:06:29

big.l
Użytkownik
Zarejestrowany: 2007.09.30
Posty: 30

Re: "apps file failure"

Przestał wypisywać mi te apps, ale zayważyłem, że jest coś innego:

(EE) AIGLX: Screen 0 is not DRI capable
xkb_keycodes      { include "xfree86+aliases(qwerty)" };
xkb_types            { include "complete" };
xkb_compatibility  { include "complete" };
xkb_symbols        { include "pc(pc105)+pl" };
xkb_geometry      { include "pc(pc105)" };
The XKEYBOARD keymap compiler (xkbcomp) reports;
> Warning:       Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                     Ignoring extra symbols
Error from xkb are not fatal to the X server

Warning: Failed to open file(/usr/share/fluxbox/nls/en_US.UTF-8/fluxbox.cat)
for translation, using default messages.

Fluxbox: There is no background option specified in this style. Please consult the manual or read the FAQ
Fluxbox: There is no background option specified in this style. Please consult the manual or read the FAQ
Fluxbox: There is no background option specified in this style. Please consult the manual or read the FAQ
FreeFontPath: FPE "/usr/share/fonts/X11/misc" refcount is 2, should be 1; fixing.

Niby to nic tragicznego, ale jeśli można się tego pozbyć, wolałbym to zrobić - od kiedy pamiętam, mam te błędy,  - może własnie przez to czasami wyłączają mi się X-y.

Offline

 

#7 2007.10.01 17:15:28

vermaden
Użytkownik
Skąd: pl_PL.lodz
Zarejestrowany: 2007.04.04
Posty: 252
System: FreeBSD UNIX 7.0
Fluxbox: SVN
WWW

Re: "apps file failure"

Kod:

(EE) AIGLX: Screen 0 is not DRI capable

W AIGLX sie nie bawilem to ci nei pomoge.

Kod:

xkb_keycodes      { include "xfree86+aliases(qwerty)" };
xkb_types            { include "complete" };
xkb_compatibility  { include "complete" };
xkb_symbols        { include "pc(pc105)+pl" };
xkb_geometry      { include "pc(pc105)" };
The XKEYBOARD keymap compiler (xkbcomp) reports;
> Warning:       Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                     Ignoring extra symbols
Error from xkb are not fatal to the X server

z tego co pamietam to jest niegrozne.

Kod:

Warning: Failed to open file(/usr/share/fluxbox/nls/en_US.UTF-8/fluxbox.cat)
for translation, using default messages.

do tego to sie chyba wszyscu juz przyzwyczaili.

Kod:

Fluxbox: There is no background option specified in this style. Please consult the manual or read the FAQ
Fluxbox: There is no background option specified in this style. Please consult the manual or read the FAQ
Fluxbox: There is no background option specified in this style. Please consult the manual or read the FAQ

Fluxbox bardzo sie zmartwil ze styl ktory sobie ustawiles nie ma zdefiniowanej tapety (nie wiem co za apach wymyslil zeby na pale laczyc styl z tapeta) wracajac do tematu, zupelnie nie grozne.

Kod:

FreeFontPath: FPE "/usr/share/fonts/X11/misc" refcount is 2, should be 1; fixing.

kolejny oldschoolowy blad, zignoruj.

W sumie tylko ten AIGLX i klawiatura (xkb) wydaja mi sie 'powazniejsze'


"religions, worst damnation of mankind"
vermaden's: links resources deviantart

Offline

 

#8 2007.10.01 18:11:19

big.l
Użytkownik
Zarejestrowany: 2007.09.30
Posty: 30

Re: "apps file failure"

Czyli tymi błędami nie będę się przejmował, szkoda tylko, ze tamte dwa pierwsze pozostają bez odpowiedzi. Szukałem w necie i nawet znalazłem poradę, żeby przekonfigurować xserver-xorg z wyłączoną opcją DRI, ale to nie pomogło, zahaszowałem DRI w xorg.conf, ale to też nie pomogło hmm

No trudno - myślę, że te dwa błędy mi wyłączają fluxboksa - podobny problem miał ktoś na innym forum, ale jego rozwiązanie mi nie pomogło

Dzieki i pozdrawiam

Offline

 

#9 2007.10.01 20:01:16

que_pasa
kaszubska zupa jagodowa na rosole
Skąd: Gdynia
Zarejestrowany: 2007.08.06
Posty: 75
System: FreeBSD 8.0-CURRENT
Fluxbox: 1.1.0.1
WWW

Re: "apps file failure"

1. w sekcji modules zahaszuj dri
2. napisz jakiej karty graficznej i jakich sterowników używasz
3. a najlepiej to pokaż swój xorg.conf
4. spróbuj skompilować fluxboxa ze źródeł. niestety nie jesteś jedynym użytkownikiem debiana (lub ubuntu) u którego coś z niewiadomych przyczyn nie działa
5. ściągnij ze strony vermadena jego cały konfig i podmień go u siebie
6. sprawdź i napisz co masz w .xinitrc, jeśli coś tam znajdziesz to wywal wszystko i dodaj: 'exec startfluxbox', po tym uruchom przez samo startx

Ostatnio edytowany przez que_pasa (2007.10.01 20:07:02)

Offline

 

#10 2007.10.02 07:53:37

big.l
Użytkownik
Zarejestrowany: 2007.09.30
Posty: 30

Re: "apps file failure"

xorg.conf:

Kod:

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
    FontPath    "/usr/share/fonts/X11/misc"
    FontPath    "/usr/X11R6/lib/X11/fonts/misc"
    FontPath    "/usr/share/fonts/X11/cyrillic"
    FontPath    "/usr/X11R6/lib/X11/fonts/cyrillic"
    FontPath    "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath    "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    FontPath    "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath    "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    FontPath    "/usr/share/fonts/X11/Type1"
    FontPath    "/usr/X11R6/lib/X11/fonts/Type1"
    FontPath    "/usr/share/fonts/X11/100dpi"
    FontPath    "/usr/X11R6/lib/X11/fonts/100dpi"
    FontPath    "/usr/share/fonts/X11/75dpi"
    FontPath    "/usr/X11R6/lib/X11/fonts/75dpi"
    # path to defoma fonts
    FontPath    "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load    "bitmap"
    Load    "ddc"
    Load    "extmod"
    Load    "freetype"
    Load    "glx"
    Load    "int10"
    Load    "vbe"
EndSection

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "pl"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device"        "/dev/psaux"
    Option        "Protocol"        "PS/2"
    Option        "Emulate3Buttons"    "true"
EndSection

Section "InputDevice"
    Identifier    "Synaptics Touchpad"
    Driver        "synaptics"
    Option        "SendCoreEvents"    "true"
    Option        "Device"        "/dev/psaux"
    Option        "Protocol"        "auto-dev"
    Option        "HorizScrollDelta"    "0"
EndSection

Section "Device"
    Identifier    "Generic Video Card"
    Driver        "sis"
    VideoRam    65536
EndSection

Section "Monitor"
    Identifier    "Generic Monitor"
    Option        "DPMS"
    HorizSync    30-98
    VertRefresh    50-160
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "Generic Video Card"
    Monitor        "Generic Monitor"
    DefaultDepth    24
    SubSection "Display"
        Depth        1
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        4
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        8
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        15
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        16
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        24
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier    "Default Layout"
    Screen        "Default Screen"
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
    InputDevice    "Synaptics Touchpad"
EndSection

#Section "DRI"
#    Mode    0666
#EndSection

Karta graficzna to zintegrowany SIS 760MG na laptopie Acer Aspire 3003NLC, sterowniki tylko te, które wybrałem podczas konfiguracji x-ów, czyli sis.
Mój FluxBox jest skompilowany ze źródeł, ale ten z paczki te same błędy wywalał
Pliku .xinitrc nie mam wcale sad - przeszykałem wszystkie pliki w systemie i go nie znalazłem

/* wstawiłem xorg.conf w znacznik code — azhag */

Ostatnio edytowany przez azhag (2007.10.02 08:45:03)

Offline

 

#11 2007.10.02 10:37:30

que_pasa
kaszubska zupa jagodowa na rosole
Skąd: Gdynia
Zarejestrowany: 2007.08.06
Posty: 75
System: FreeBSD 8.0-CURRENT
Fluxbox: 1.1.0.1
WWW

Re: "apps file failure"

na początek do xorg.conf dodaj to

Kod:

Section "Extensions"
    Option "Composite" "Disable"
EndSection

Section "ServerFlags"
     Option "AIGLX" "Enabled"
     Option "Xinerama" "Disabled"
EndSection

Section "Modules"
     Option "DRI" "Disabled"
EndSection

przy AIGLX spróbuj również opcji disabled.

Wyłącz w kernelu taką opcję:
"framebuffer device interface" (nie jestem pewien czy na pewno dobrze podałem, nie używam linuksa)

w ostateczności zainstaluj nan nowo xorga:

Kod:

# apt-get remove xserve-xorg-core
# apt-get install xserve-xorg-core

i ewentualnie:

Kod:

# dpkg-reconfigure xserver-xorg

co do pliku .xinitrc to utwórz go w katalogu domowym, dodaj

Kod:

exec startfluxbox

i uruchamiaj przez samo startx

Ostatnio edytowany przez que_pasa (2007.10.02 10:49:32)

Offline

 

#12 2007.10.02 10:54:19

vermaden
Użytkownik
Skąd: pl_PL.lodz
Zarejestrowany: 2007.04.04
Posty: 252
System: FreeBSD UNIX 7.0
Fluxbox: SVN
WWW

Re: "apps file failure"

ja bym jescze takiego lite configa wyprobowal:

Kod:

Section "Files"
    FontPath    "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load    "extmod"
    Load    "dbe"
EndSection

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "pl"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device"        "/dev/psaux"
    Option        "Protocol"        "PS/2"
    Option        "Emulate3Buttons"    "true"
EndSection

Section "InputDevice"
    Identifier    "Synaptics Touchpad"
    Driver        "synaptics"
    Option        "SendCoreEvents"    "true"
    Option        "Device"        "/dev/psaux"
    Option        "Protocol"        "auto-dev"
    Option        "HorizScrollDelta"    "0"
EndSection

Section "Device"
    Identifier    "Generic Video Card"
    Driver        "sis"
    VideoRam    65536
EndSection

Section "Monitor"
    Identifier    "Generic Monitor"
    Option        "DPMS"
    HorizSync    30-98
    VertRefresh    50-160
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "Generic Video Card"
    Monitor        "Generic Monitor"
    DefaultDepth    24
    SubSection "Display"
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier    "Default Layout"
    Screen        "Default Screen"
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
    InputDevice    "Synaptics Touchpad"
EndSection

"religions, worst damnation of mankind"
vermaden's: links resources deviantart

Offline

 

#13 2007.10.02 10:58:01

que_pasa
kaszubska zupa jagodowa na rosole
Skąd: Gdynia
Zarejestrowany: 2007.08.06
Posty: 75
System: FreeBSD 8.0-CURRENT
Fluxbox: 1.1.0.1
WWW

Re: "apps file failure"

pomysł vermadena na zostawienie tylko 24 bitowego kolory jest świetny. twoja karta graficzna nie obsługuje DRI. Je śli masz gdzieś pod reką livecd z ubuntu to sprawdź czy się uruchamia, jak tak to z tamtą skopiuj xorg.conf

Offline

 

#14 2007.10.02 18:39:41

big.l
Użytkownik
Zarejestrowany: 2007.09.30
Posty: 30

Re: "apps file failure"

Hmm, nie chciał odpalić się gdy cokolwiek kombinowałem w xorg.conf sad ciągle mu coś nie pasowało, a próbowałem wielu rzeczy...
Teraz x-y się odpalają, ale wysypują przy okazji inne błędy:

(EE) AIGLX: Screen 0 is not DRI capable
expected keysym, got XF86KbdLightOnOff: line 70 of pc
expected keysym, got XF86KbdBrightnessDown: line 71 of pc
expected keysym, got XF86KbdBrightnessUp: line 71 of pc

Offline

 

#15 2007.10.02 18:41:52

que_pasa
kaszubska zupa jagodowa na rosole
Skąd: Gdynia
Zarejestrowany: 2007.08.06
Posty: 75
System: FreeBSD 8.0-CURRENT
Fluxbox: 1.1.0.1
WWW

Offline

 

#16 2007.10.02 19:19:07

big.l
Użytkownik
Zarejestrowany: 2007.09.30
Posty: 30

Re: "apps file failure"

Kurde, no - nie mam siły już ... ściągnąłem sterownik, zainstalowałem według opisu uruchamiam x-y i wszystko staje w miejscu na czarnym ekranie sad

Offline

 

#17 2007.10.02 20:56:24

que_pasa
kaszubska zupa jagodowa na rosole
Skąd: Gdynia
Zarejestrowany: 2007.08.06
Posty: 75
System: FreeBSD 8.0-CURRENT
Fluxbox: 1.1.0.1
WWW

Re: "apps file failure"

pozostaje spróbowanie czegoś innego niż debia smile odpalałeś jakieś livecd? może zamiast pingwina wybierz demona smile
na dobrą sprawę to nawet łatwiejsze w konfiguracji smile

Offline

 

#18 2007.10.02 21:12:59

big.l
Użytkownik
Zarejestrowany: 2007.09.30
Posty: 30

Re: "apps file failure"

zrobiłem aktualizację systemu do Lenny - wprawdzie są te same błędy, ale x-y nie wyłączają się - sprawdzę jeszcze to przez kilka dni - jesli będzie wszystko ok, oleje te błędy i będe tak korzystał smile

Debian mi leży jakoś smile Trochę się boję BSD wink

Dzięki za pomoc
Pozdrawiam

Offline

 

#19 2007.10.03 07:32:52

que_pasa
kaszubska zupa jagodowa na rosole
Skąd: Gdynia
Zarejestrowany: 2007.08.06
Posty: 75
System: FreeBSD 8.0-CURRENT
Fluxbox: 1.1.0.1
WWW

Re: "apps file failure"

ja dopiero raczkuję w *unixach. FreeBSD wybrałem, bo tam wszystko okazało się jednak prostsze (moje podejście do linuxa, m. in. do debiana i ubuntu okazało się klapą) . Jest świetnie udokumentowany, właściwie wszystko masz w podręczniku.

Ostatnio edytowany przez que_pasa (2007.10.03 07:33:42)

Offline

 

#20 2007.10.03 11:23:02

big.l
Użytkownik
Zarejestrowany: 2007.09.30
Posty: 30

Re: "apps file failure"

Ja kiedyś używałem FreeBSD, nawet podobał mi się, ale wtedy jeszcze nie wiedziałem o systemach Uniksowych praktycznie nic i chyba nie do końca wiedziałem po co mi taki system. Miałem długą przerwe (windows), a potem znowu powróciłem do Uniksów ale tym razem wybrałem Linuksa. Pamiętam, że FreeBSD był świetnie udokumentowany - na wszystko były w necie howto itp - zupełnie jak gentoo. Może zacząłbym go używać, ale jednak na uczelni wymaga się ode mnie bardziej znajomości Linuksa niż Uniksa. Wprawdzie *BSD to nie do końca systemy Unix, ale o wiele bliżej im do Uniksa niż Linuksowi smile
Zajmuje się serwisem komputerów na uczelni i pomocą administratora, a tam wszystko chodzi na Linuksach - Debian & Slackware, dlatego narazie na BSD nie mogę sobie pozwolić smile
Ale myślę, że prędzej czy później zainstaluje go - kwestia kiedy znajdę czas. Narazie mam na to za dużo przedmiotów: C++/Java/Visual Basic, elektronika, oprogramowanie prac biurowych, systemy operacyjne, grafika, matematyka, a do tego robię kurs Cisco CCNA - trochę mam tego na głowie - wystarczająco, żeby nie móc znaleźć czasu na eksperymentowanie z Uniksami, ale jak zwolni się trochę czasu, czemu nie smile

Pozdrawiam

Offline

 

#21 2007.10.03 13:41:45

que_pasa
kaszubska zupa jagodowa na rosole
Skąd: Gdynia
Zarejestrowany: 2007.08.06
Posty: 75
System: FreeBSD 8.0-CURRENT
Fluxbox: 1.1.0.1
WWW

Re: "apps file failure"

no chyba że tak smile

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson